Payment processing with external card readers
Incident Report for SQUIRE Status Page
Resolved
Since our last update, we have observed all payment processing methods have returned to normal operation, this incident is now considered resolved. If you have any further questions, please contact our support team via chat in-app.
Posted Apr 17, 2023 - 02:32 EDT
Identified
SQUIRE Engineers have identified an issue impacting payment processing with an external card reader. As a temporary workaround, we recommend using manual entry. Please view this link for help: https://getsqr.co/MbuEK0
Posted Apr 17, 2023 - 01:31 EDT
Investigating
SQUIRE Support has received reports of an inability to process payments. SQUIRE Engineers are actively investigating the issue.
Posted Apr 17, 2023 - 00:29 EDT
This incident affected: Services (Payments) and SQUIRE.