SQUIRE is happy to report that the issue with our booking partner has been resolved. Google Booking is functioning as expected. If you are still experiencing an issue, reach out to our support team directly.
Posted Dec 07, 2023 - 09:45 EST
Identified
We have identified the issue and have confirmed this is impacting a very small number (
If a client reaches out, please redirect them to the many other ways they can book. In most, but not all cases, refreshing the booking page can also resolve the issue.
We will continue to work with Google to ensure all bookings are complete without issue. We appreciate your patience.
Posted Dec 06, 2023 - 22:38 EST
Update
SQUIRE is continuing to monitor the issue with Google Booking and working with our booking partner. We will provide an update as soon as the issue is resolved. We appreciate your patience as we continue to work through this issue as quickly as possible. Please redirect your clients to book with booking links or SQUIRE booking apps.
Posted Dec 06, 2023 - 16:55 EST
Investigating
SQUIRE is investigating an issue impacting Google Booking where clients are getting an error message "An error occurred while scheduling your booking." Please redirect customers to shop booking links or SQUIRE booking apps. We are actively investigating the situation with our booking partners and will update you as soon as we have more information.
Posted Dec 06, 2023 - 10:56 EST
This incident affected: 3rd-Party Booking (Reserve with Google).