Payment Processing Issue
Incident Report for SQUIRE Status Page
Resolved
SQUIRE is happy to report that the issue has been resolved. If you are still experiencing an issue or having difficulty getting clients charged, reach out to our support team directly.
Posted Aug 23, 2023 - 13:08 EDT
Investigating
Transactions over 100 USD cannot be processed using SQUIRE using a credit card reader with your browser. Our team is working to resolve this issue. In the meantime, these payments can be successfully processed through your web browser or on an iPad by manually entering the CC number. You can also create a custom charge on iPad to avoid this temporary issue. We will share more updates shortly.
Posted Aug 23, 2023 - 12:23 EDT
This incident affected: Services (Payments).