3rd-Party Bank Deposits
Incident Report for SQUIRE Status Page
Resolved
This incident has been resolved.
Posted Nov 06, 2023 - 12:52 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 03, 2023 - 22:14 EDT
Monitoring
We are aware of potential delays in deposits, related to an error at a payment processing network, as reported by the Federal Reserve. Wells Fargo, US Bank, Chase and Truist are among the major national banks impacted. We recommend checking with your bank regarding any deposit delays.
Posted Nov 03, 2023 - 19:08 EDT
This incident affected: 3rd-Party Payments (Stripe).