Google Booking Integration
Incident Report for SQUIRE Status Page
Resolved
This incident has been resolved.
Posted Aug 16, 2024 - 15:39 EDT
Monitoring
SQUIRE is rolling out an improved Google Booking Integration. During this update, for some SQUIRE customers, the "Book Now" button on your Google Profile will be unavailable from August 16th until early next week. All other booking methods will remain functional.

To ensure seamless bookings, update the “Website” field on your Google Business Profile with your website or SQUIRE booking link:

1. Log in to your Google Business Profile.
2. Go to the “Info” section.
3. Update the “Website” field.
4. Save the changes.

For assistance, our support team is here to help
Posted Aug 15, 2024 - 18:59 EDT
This incident affected: 3rd-Party Booking (Reserve with Google).