SQUIRE Unavailable

Incident Report for SQUIRE Status Page

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 13:56 EDT

Monitoring

This incident has been resolved and fully restored. We are continuing to monitor. Thank you for your patience.
Posted Jul 09, 2026 - 13:48 EDT

Identified

We've identified the issue and are working to fully restore services. Systems are recovering, but some customers may experience latency. Our team is continuing to work on a full resolution and is monitoring the system closely. We will post additional updates as available.
Posted Jul 09, 2026 - 13:18 EDT

Update

We are continuing to investigate this issue.
Posted Jul 09, 2026 - 12:42 EDT

Investigating

SQUIRE is investigating an issue where SQUIRE is not accessible for customers. We are actively investigating the situation with our engineering team and will update you as soon as we have more information. We appreciate your patience while we work to address the issue.
Posted Jul 09, 2026 - 12:37 EDT
This incident affected: SQUIRE.