SQUIRE is happy to report that the issue with our partner has been resolved. If you are still having an issue, please reach out to our support team directly.
Posted Nov 18, 2025 - 12:55 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 10:36 EST
Update
The issue impacting Cloudflare is resolving. SQUIRE is continuing to monitor recovery. If you are still having an issue, please reach out to our support team.
Posted Nov 18, 2025 - 10:05 EST
Monitoring
SQUIRE is continuing to monitor the issue with our partner Cloudflare and will provide an update as soon as the issue is resolved. We appreciate your patience as we continue to work through this issue as quickly as possible.
Posted Nov 18, 2025 - 08:33 EST
Investigating
SQUIRE is investigating an issue impacting our systems due to an issue with our partner Cloudflare. We are actively investigating the situation with our booking partners and will update you as soon as we have more information.