Stripe “Request rate limit exceeded” error message
Incident Report for SQUIRE Status Page
Resolved
Our 3rd party partner, Stripe has now declared their internal incident resolved and all services are now available. If you have any further questions, please contact our support team via chat in-app.
Posted Jun 30, 2023 - 12:34 EDT
Investigating
Our 3rd party partner, Stripe is currently experiencing a service incident where some users are receiving an “Request rate limit exceeded” error message. We are monitoring the incident at our partner service and will provide an update as soon as their incident is cleared.
Posted Jun 30, 2023 - 11:59 EDT
This incident affected: 3rd-Party Payments (Stripe).