Barber booking links
Incident Report for SQUIRE Status Page
Resolved
SQUIRE is happy to report that the issue with our partner has been resolved. If you are still experiencing an issue, reach out to our suppor team directly.
Posted Apr 04, 2024 - 13:05 EDT
Monitoring
SQUIRE is continuing to monitor the issue with our partner and will provide an update as soon as the issue is resolved. We appreciate your patience as we continue to work through this issue as quickly as possible.
Posted Apr 04, 2024 - 12:50 EDT
Investigating
SQUIRE is investigating an issue impacting barber booking links with our partner. Please contact the shop directly or download our SQUIRE booking app to make an appointment. We will update you as soon as we have more information.
Posted Apr 04, 2024 - 12:30 EDT
This incident affected: 3rd-Party URL Shortner (getsqr.co (short.io)).