SQUIRE SMS Delivery

Incident Report for SQUIRE Status Page

Identified

We have identified the issue affecting SMS message delivery, preventing some customers from receiving SMS verification codes and appointment reminders. Marketing communications sent through Engage are unaffected. Our engineering team is working on a fix. We will provide an update as soon as we have more information. We appreciate your patience while we work to address the issue.
Posted May 25, 2026 - 09:16 EDT

Investigating

SQUIRE is investigating an issue affecting SMS message delivery. Some customers may be unable to receive SMS verification codes required to log in, and appointment reminders sent via SMS may be delayed or undelivered. Marketing communications sent through Engage are unaffected. We are actively investigating the situation and will provide an update as soon as we have more information. We appreciate your patience while we work to address the issue.
Posted May 24, 2026 - 22:23 EDT
This incident affects: 3rd-Party Communications (MessageBird) and SQUIRE.