SQUIRE Slowness

Incident Report for SQUIRE Status Page

Identified

We have identified the issue. A system outage with one of our search partners is affecting the ability to look up clients and appointments in SQUIRE. All other systems are operating normally.

Our team is actively exploring options to mitigate the impact in this area while the partner works to restore service. We will post an update as soon as we have more information.
Posted Jun 05, 2026 - 12:12 EDT

Investigating

We are currently investigating reports of slowness when performing certain functions in SQUIRE. Some users may experience delays. Our team is actively looking into the cause and working to restore normal performance. We will post an update as soon as we have more information.
Posted Jun 05, 2026 - 12:02 EDT
This incident affects: SQUIRE.