SQUIRE Slowness and Intermittent Errors

Incident Report for SQUIRE Status Page

Resolved

SQUIRE is happy to report that the issue has been resolved. If you are still experiencing an issue with accessing SQUIRE, please do not hesitate to reach out to our support team directly.
Posted Nov 05, 2025 - 17:20 EST

Investigating

We are investigating an issue where SQUIRE is not accessible for some customers. We are actively investigating the situation with our engineering team and will notify you as soon as we have more information. We appreciate your patience while we work to address the issue.
Posted Nov 05, 2025 - 16:55 EST
This incident affected: SQUIRE.